Upgrade Windows 10 Home do Windows 10 , bez reintalacji

Upgrade Windows 10 ( home ) do Windows 10

Ostatnio wpadł temat.
Jak podnieść wersję Windows 10 home do Windows 10 (Pro). Bez konieczności reinstalacji całego systemu.

 

Oczywiście mamy wykupiony nowy klucz dla Windows 10 Pro

Na początek sprawdzamy jaka wersje mamy.  odpalamy Powershell -a  ( w trybie admistracyjnym )

DISM /online /Get-CurrentEdition

Teraz sprawdzamy do jakiej wersji możemy podnieść system

dism /Online /Get-TargetEditions

Ja zrobiłem tak

sc config LicenseManager start= auto & net start LicenseManager

sc config wuauserv start= auto & net start wuauserv

Teraz podajemy nowy numer licencji

cmd w trybie Admina

changepk.exe /productkey XXXXX-XXXXX-XXXXX-XXXXX-XXXXX
PowerShell informacje z Bios

PowerShell informacje z Bios

Powershell  -numer seryjny ;  -informacje z BIOS

 

Czasami jest potrzeby nr seryjny Komputera, laptopa itp.

Można się wczytywać w małe ledwo widoczne szlaczki pod laptopem , lub zanurkować pod biurko i szukać s/n

Ale….

Klasa Win32_BIOS WMI reprezentuje atrybuty podstawowych usług wejścia/wyjścia (BIOS) systemu komputerowego, które są zainstalowane na komputerze.

Możliwości ( parametry)

'BiosCharacteristics','BIOSVersion','BuildNumber','Caption','CodeSet',
'CurrentLanguage','Description','EmbeddedControllerMajorVersion',
'EmbeddedControllerMinorVersion', 'IdentificationCode','InstallableLanguages',
'InstallDate','LanguageEdition','ListOfLanguages', 'Manufacturer','Name',
'OtherTargetOS','PrimaryBIOS','ReleaseDate',
'SerialNumber','SMBIOSBIOSVersion',
 'SMBIOSMajorVersion','SMBIOSMinorVersion','SMBIOSPresent',
'SoftwareElementID','SoftwareElementState', 'Status',
'SystemBiosMajorVersion','SystemBiosMinorVersion','TargetOperatingSystem','Version' 

LUB  wszystkie parametry ze znakiem * przykład niżej

 

Można też skorzystać z funkcji PowerSell Windows

Odpalamy Powershell-a

-wystarczy wpisać w lub wyszukać  Powershell

Kod Powershell -a

  Get-CimInstance -ClassName Win32_BIOS -Property *

i oto mamy

 

Status : OK
Name : Phoenix BIOS SC-T v2.2
Caption : Phoenix BIOS SC-T v2.2
SMBIOSPresent : True
Description : Phoenix BIOS SC-T v2.2
InstallDate :
BuildNumber :
CodeSet :
IdentificationCode :
LanguageEdition :
Manufacturer : LENOVO
OtherTargetOS :
SerialNumber : PB11X6C                                             — numer Seryjny
SoftwareElementID : Phoenix BIOS SC-T v2.2
SoftwareElementState : 3
TargetOperatingSystem : 0
Version : LENOVO – 2820
PrimaryBIOS : True
BiosCharacteristics : {7, 9, 11, 12…}
BIOSVersion : {LENOVO – 2820, Phoenix BIOS SC-T v2.2}
CurrentLanguage : en-US
EmbeddedControllerMajorVersion : 1
EmbeddedControllerMinorVersion : 14
InstallableLanguages : 1
ListOfLanguages : {en-US}
ReleaseDate : 2019-08-07 02:00:00
SMBIOSBIOSVersion : G1ETC2WW (2.82 )
SMBIOSMajorVersion : 2
SMBIOSMinorVersion : 7
SystemBiosMajorVersion : 2
SystemBiosMinorVersion : 82
PSComputerName :
CimClass : root/cimv2:Win32_BIOS
CimInstanceProperties : {Caption, Description, InstallDate, Name…}
CimSystemProperties : Microsoft.Management.Infrastructure.CimSystemProperties

Można krócej

Get-WmiObject WIN32_BIOS

SMBIOSBIOSVersion : G1ETC2WW (2.82 )
Manufacturer : LENOVO
Name : Phoenix BIOS SC-T v2.2
SerialNumber : PB11X6C
Version : LENOVO – 2820

Lista najciekawszych , lub tez tych co mi się przydają
Win32_computerSystem --podstawowe parametry ilosc pam, hostname, Vendor
Win32_bios -- przykład u góry
Win32_baseboard    -- (Motherboard s/n Producent)
Win32_processor    --(32+64 bit processor info)
Win32_Share        -- (udostępniane zasoby ,File shares)
Win32_LogicalDisk   --(hard disk)
Win32_PhysicalMemory
Win32_Printer
Win32_Product --(Zainstalowane Aplikacje z nr Wersi !!!!! (Warning avoid this: Installed programs will reconfigure see Q974524)
Win32reg_AddRemovePrograms (Installed 32 bit programs with SCCM client)
Win32Reg_AddRemovePrograms64 (Installed 64 bit programs with SCCM client)
Instalacja Windows 7  Partycja GPT

Instalacja Windows 7 Partycja GPT

Instalacja Windows 7  błąd.  Partycja GPT  zobacz jak szybko rozwiązać problem

Problem : Jeżeli widzisz ta ki ekran to czytaj dalej jak szybko zainstalować system Windows na twoim komputerze lub laptopieBłąd instalacja windows Partcja GPT

Komunikat widoczny podczas instalacji Windows Informujący, że nie można zainstalować systemu na partycji GPTRozwiązanie

(!!!!      UWAGA TA OPCJA SKASUJE WSZYSTKIE DANE Z TWOJEGO DYSKU   !!!!!!!! )

Nie wychodząc z procesu instalacji  wciskamy

SHIFT+F10 ( lub SHIFT+Fn+F10)

Lub prościej, jeżeli widzisz to co na obrazku naciśnij OK  a następnie SHIFT i klawisz F10 )

Wyskakuje okno CMD  (takie czarne 🙂 ) i lecimy czyli wpisujemy

Partycja GTP

ekran diskpart

1 ) diskpart  
2) list disk ( Zobaczmy listę wszystkich dysków podłączonych do urządzenia).
3) select disk X  (0 jeżeli jest to jedyny widoczny ,   Za X wstawiamy numer dysku który chcemy przekonwertować ).
4) clean
5) convert mbr
6) exit

i już  wracamy z powrotem do naszej instalacji

A Co to jest  GTP lub  Partycja GPT

  • GTP to nowy system ( sposób , nowe rozwiązanie ) w jaki sposób dane na dysku będą zapisywane. Opracowany przez firmę Intel
  • Ma on wiele zalet przede wszystkim możliwości tworzenie DUUUżych partycji na dysku np 256 TB (ograniczeniami rozmiaru zależnymi od systemu operacyjnego i systemów plików)
  • Prawie brak ograniczeń ilości partycji  (  Windows dopuszcza do 128 partycji na dysku GPT i nie musisz tworzyć rozszerzonej partycji, aby działały)
  • GPT przechowuje wiele kopii (partycjonowania i rozruchu), tych danych na dysku, dlatego jest  bardziej odporny na uszkodzenia ,oraz można  odzyskać dane , jeśli dane są uszkodzone

Jeśli składasz nowy komputer PC lub po dodajesz nowy dysk twardy, musisz wybrać jak go  sformatować. Gdy tylko system Windows wykryje nowy, pusty dysk, poprosi Cię o jego inicjalizacje i wybranie spośród tych dwóch formatów:

  • MBR (Master Boot Record)
  • GPT (GUID Partition Table)

więcej o UEFI i GPT  tutaj oraz wikipedia (en)

 

Mikrotik VPN L2TP+IPSEC do MS Windows

MikroTik jako serwer VPN w oparciu o protokół L2TP z szyfrowaniem IPSEC z wykorzystaniem klucza.

Na routerze MikroTik przed przystąpieniem do konfiguracji serwera VPN stworzyłem typową konfiguracji domowego routera (NAT, DHCP, DNS, prosty firewall)

  1. W pierwszej kolejności musimy utworzyć użytkownika VPN. Aby to zrobićprzechodzimy w menu PPP do zakładki Secrects.
  2. Klikamy dodaj, w nowym oknie wpisujemy nazwę użytkownika, hasło,wybieramy rodzaj tunelu jaki będzie używany przez tego użytkownika (w tymprzypadku l2tp). Następnie podajemy Local Address (ten adres pojawi się w /ipaddress po zestawieniu tunelu) następnie podajemy Remote Address. Adresywykorzystywane w tunelu nie muszą być (chodź mogą) wykorzystywane w sieciLAN. W polu Remote Address można wybrać pulę adresów (którą wcześniejdefiniujemy w /ip pool).
    Możemy również stworzyć własny profil przechodząc do zakładki Profiles w menuPPP. Możemy m.in. nadać w profilu local adres który będzie obowiązywał dlawszystkich użytkowników korzystających z tego profilu. Dla przykładu, gdy wprofilu wpiszemy adres lokalny, a w remote adres wybierzemy pulę adresówbędziemy mogli tworzyć użytkowników podając tylko ich login i hasło reszta będzieposługiwać się danymi z profilu.

Jeżeli w konfiguracji użytkownika podamy innedane będą one ważniejsze niż te z profilu i zostaną użyte w tunelu.

/ppp secret
add local-address=192.168.50.10 name=l2tp_user password=ZAQ!2wsx
profile=default-encryption remote-address=192.168.50.1 service=l2tp

Następnie w menu PPP przechodzimy do zakładki Interface aby włączyć serwerL2TP. Klikamy w przycisk L2TP Server, zaznaczamy Enable, jako profil wybieramydefault-encryption, jako autentykację odznaczamy wszystko oprócz mschap2 (jestto algorytm dostępny w większości urządzeń i systemów operacyjnych). W poluUse IPsec wybieramy require (IPsec będzie wymagany do nawiązania połączenia),w polu IPsec Secret wpisujemy klucz szyfrujący transmisję (klucz będzie taki samdla wszystkich użytkowników).

 

/interface l2tp-server serverset authentication=mschap2 enabled=yes ipsec-secret=HasloIPSec useipsec=required

Dla tego typu tunelu na firewallu należy wprowadzić:

ACCEPT INPUT, Protocol UDP, Dst. Port 4500

ACCEPT INPUT, Protocol UDP, Dst. Port 500

ACCEPT INPUT, Protocol UDP, Dst. Port 1701

/ip firewall filter
 add action=accept chain=input dst-port=4500 protocol=udp
 add action=accept chain=input dst-port=500 protocol=udp
 add action=accept chain=input dst-port=1701 protocol=udp

 

Konfiguracja klienta na przykładzie Windows 7 wygląda następująco:

– wchodzimy w centrum sieci i udostępniania– klikamy w „Skonfiguruj nowe połączenie lub nową sieć”

– połącz z miejscem pracy– użyj mojego połączenia internetowego (VPN)

– w polu Adres internetowy wpisujemy publiczny adres IP naszego routera,ustalamy nazwę połączenia, zaznaczamy „Nie łącz teraz, tylko skonfiguruj…” iklikamy dalej

– wpisujemy nazwę użytkownika i hasło zdefiniowane w PPP/Secrets

– zamykamy kreator– wchodzimy w „Zmień ustawienia karty sieciowej”

– na utworzonym połączeniu VPN klikamy w właściwości

– wybieramy zakładkę „Zabezpieczenia”

– wybieramy „Typ wirtualnej sieci prywatnej (VPN) jako”. Protokół L2TP/IPSec” a wpolu Szyfrowanie danych wybieramy Najmocniejsze szyfrowanie, w poluUwierzytelnianie zaznaczany „Zezwalaj na użycie tych protokołów” i zostawiamyzaznaczone Microsoft CHAP wersja 2

– wchodzimy w Ustawienia zaawansowane, zaznaczamy „użyj kluczawstępnego…” i wpisujemy nasz IPsec Secret zdefiniowany u ustawieniach serwerana routerze i klikamy OK

Podłączamy się do sieci VPN klikając podwójnie na utworzone połączenie i wpisując dane zdefiniowane w PPP/Secrets.

Urządzenie które podłączy się do VPN będzie miało komunikację L3 z hostami sieci lokalnej. Ruchem tym można zarządzać odpowiednimi regułami /ip firewall

UWAGA: Jeżeli planujesz uruchomić serwer VPN na routerze będącym za NAT’em (w sieci lokalnej) pomimo utworzenia prawidłowych reguł na routerze brzegowym(przekierowań portów 500,4500,1701) i konfiguracji serwera VPN stacje klienckie z systemami Windows mogą mieć problemy z połączeniem.

Rozwiązaniem jest edycjarejestru (polecenie CMD jako administrator):

REG ADD HKLM\SYSTEM\CurrentControlSet\Services\PolicyAgent /v AssumeUDPEncapsulationContextOnSendRule /t REG_DWORD /d 2

 

Autor: Wojciech Mańka

Pokaż Pulpit Windows 10

Pokaż Pulpit Windows 10

! dla Klika-czy
  • Kliknij prawym klawiszem myszy na pulpicie
  • Nowy skrót
  • WKLEJ
%windir%\explorer.exe shell:::{3080F90D-D7AD-11D9-BD98-0000947B0257}

  • Nadaj Nazwę np Pulpit
  • Jeszce raz Prawym na nowej ikonie i wybieramy właściwości > Zmień ikonę
  • Wpisz w polu       ścieżki         %systemroot%\System32\imageres.dll
     

Przeciągnij na Pasek systemowy   i GOTOWE

 

DLA Leniwych
TU
Boot sektor  Windows 7  naprawa

Boot sektor Windows 7 naprawa

Automatyczna naprawa za pomocą Narzędzia do naprawy systemu podczas uruchomienia

Naprawa 1
  1.  Włóż do napędu płytę z odpowiednią wersją instalacyjną System. Rożne wersje systemu nie pomogą i  naprawa BCD sie nie uda
  2. Uruchom ponownie komputer.
  3. Kiedy pojawi się napis „Press any key to boot from CD or DVD” wciśnij dowolny klawisz.
  4. Zatwierdzamy klawiatury  i region następny ekran
  5. Kliknij: „Napraw komputer”
  6. Teraz kreator spróbuje odnaleźć zainstalowany system. Upewnij się, że jest zaznaczona pierwsza opcja – „Użyj narzędzi odzyskiwania (…)” i kliknij dalej.
  7. Jeżeli pojawi się okienko z zapytaniem czy chcesz przywrócić system kliknij „Anuluj”
  8. Pojawi się kolejne okno. Wybierz ostatnią opcję „Wiersz poleceń”
  9. W okienku które się pojawiło wpisz:

bootrec /fixmbr – aby naprawić uszkodzony sektor.

bootrec /fixboot

bootrec /rebuildbcd

Powinien znaleźć zainstalowane wersja systemu Windows .Potwierdzasz naprawę klawiszem T

Naprawa MBR


 bootrec.exe /fixmbr
 bootsect.exe /nt60 all /force /mbr
 (narzędzie znajduje się na płycie instalacyjnej w folderze x:\boot; przełącznik /force wymusza nadpisanie mbr
Te polecenia pozwalają naprawić główny rekord rozruchowy (MBR).

Naprawa boot sectora

 bootrec.exe /fixboot
bootsect /nt60 C:\ (naprawa partycji c:)
 bootsect /nt60 SYS (naprawa partycji systemowej)
 bootsect /nt60 ALL (naprawa wszystkich partycji)
 Polecenia do naprawy boot sektora partycji

Odbudowa magazynu BCD
Komenda: bootrec.exe /rebuildbcd
polecenie skanuje dysk w poszukiwaniu instalacji Windows 7 i pozwala dodać daną instalacje do magazynu BCD. Komunikat, że zidentyfikowano 0 instalacji oznacza, że nie znaleziono żadnych nowych instalacji oprócz tych, które już znajdują się na liście rozruchu.
  1.  Włóż do napędu płytę z odpowiednią wersją instalacyjną System. Rożne wersje systemu nie pomogą i  naprawa BCD sie nie uda
  2. Uruchom ponownie komputer.
  3. Kiedy pojawi się napis „Press any key to boot from CD or DVD” wciśnij dowolny klawisz.
  4. Zatwierdzamy klawiatury  i region następny ekran
  5. Kliknij: „Napraw komputer”
  6. Teraz kreator spróbuje odnaleźć zainstalowany system. Upewnij się, że jest zaznaczona pierwsza opcja – „Użyj narzędzi odzyskiwania (…)” i kliknij dalej.
  7. Jeżeli pojawi się okienko z zapytaniem czy chcesz przywrócić system kliknij „Anuluj”
  8. Pojawi się kolejne okno. Wybierz ostatnią opcję „Wiersz poleceń”
  9. W okienku które się pojawiło wpisz:

bootrec /fixmbr – jeżeli chcesz zapisać główny sektor rozruchowy zgodny z Windows 7. I/lub:

bootrec /fixboot – aby naprawić uszkodzony sektor.

bootrec /rebuildbcd

Powinien znaleźć zainstalowane wersja systemu Windows .Potwierdzasz naprawę klawiszem T

 

LUB

Wpisz Bootrec.exe, a następnie naciśnij klawisz ENTER.

Opcje narzędzia Bootrec.exe
Ta procedura gwarantuje pełną odbudowę magazynu BCD. W celu jej wykonania wpisz następujące polecenia w wierszu polecenia:

bcdedit /export c:\bcdbackup                (wykonujemy backup magazynu)

attrib c:\boot\bcd -h -r -s                       (usuwamy atrybuty)

ren c:\boot\bcd bcd.old                       (zmieniamy nazwę dotychczasowego magazynu)

bootrec /RebuildBcd

Link https://answers.microsoft.com/pl-pl/windows/forum/windows_xp-windows_install/przywracanie-sektora-rozruchowego-windows-7/b1a02e8a-41fe-45dd-96dd-7726ed135ec2

Windows XP

Edycja i konfigurowanie BCD
Edycja jak w XP: Zakładka Uruchamianie i odzyskiwanie we Właściwościach systemu czy MSConfig.exe, karta Rozruch.
BCDEdit.exe służy do zarządzania magazynem BCD, obsługa z Wiersza poleceń, zastępuje narzędzie Bootcfg.exe z Windows XP.
bcdedit /enum – wyświetla listę wpisów w magazynie

Odzyskanie relacji zaufania PC Serwer Windows

Odzyskanie relacji zaufania PC – domena MS

Długo niewłączany PC (np. 60 dni) traci połączenie z domeną – nie można się zalogować przy użyciu konta domenowego. Można naprawić to logując się na konto lokalnego admina, odłączyć PC od domeny i ponownie podpiąć.

Właściwe pytanie brzmi: czy można to zrobić szybciej, łatwiej, efektywniej np. z linii komend?

Można tak
Jasne, że można, np. tak:

dsmod computer “ComputerDN” -reset

ale potrzebny rejoin i restart

lub

netdom reset MachineName /domain DomainName /UserO UserName /PasswordO {Password | *}

tutaj zmiana wykonuje się na DC i CL, więc nie wymagany rejoin ani reboot

lub tak:

nltest /server:servername /sc_reset:domain\domaincontroller

lub jeszcze tak, na samym kliencie z PowerShell:

Test-ComputerSecureChannel -Repair